[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Stray character in input

From: Paul Studdart
Subject: Stray character in input
Date: Sat, 03 Apr 2004 09:01:02 +0100

I am running cfengine 2.1.3 for configuring some compute clusters.
Recently I added a second cluster and wanted to use the same
configuration files with an additional section that created different
macros depending on the cluster it was working with. Since each cluster
is in a different domain I decided to test against the domain class set
up by the cfengine program. On my test cluster at home this worked fine
but when I tried it at work it fails with an error message: Syntax error
 Stray character in input (-)

The relevant parts of the config file are:-

  # Home cluster
    macros .......

  # Work Scooby Cluster
    macros ........

So it looks like it's the - character in the domain name that is the
cause of the problem. Since I cannot change the domain name assigned to
the organisation is there any way of escaping the - character in this
instance. I could create a mythical top level domain on the clusters
name servers but I would prefer another solution.

Any help, suggestions would be very gratefully received.

Paul Studdart

reply via email to

[Prev in Thread] Current Thread [Next in Thread]