[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h-e-w] RE: help-emacs-windows Digest, Vol 13, Issue 15

From: Stephen Leake
Subject: Re: [h-e-w] RE: help-emacs-windows Digest, Vol 13, Issue 15
Date: 22 Sep 2004 10:10:22 -0400
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.3

"Geert Ribbers" <address@hidden> writes:

> I didn't try C-q C-J, I did now, but it doesn't help.
> I just can't get to the process.
> Calling the process with (start-process or with (make-comint-in-buffer has
> the same result.

This is a general Cygwin/Windows/Emacs issue; some executables run in
subprocesses under Emacs don't prompt properly. Something about
setting the tty to some mode; I don't remember the details.

For ssh and cvs, when I know I'm going to be prompted for a password,
I run in a plain bash window (not under Emacs). Fortunately, I only
need to do that once, to set up ssh-agent; then I can do everything
under Emacs. I hope subversion works the same way.

> Also sending (process-send-string <process> <answer-to-the-prompt>)
> doesn't help. Typing the same command in a windows-shell works
> perfectly, there is no firewall issue here therefore. The only
> things is that I can't reach the process as soon a I try to do it in
> emacs.
> BTW: I do have and use the svn-integration with emacs (vc-svn and psvn).
> The point is: I'm trying to send commands like svn list and svn copy which
> are not in any integration available as far as I know.

Hmm. So it's not just passwords. That's bad. Perhaps you need to get
on the svn developers list and raise this issue. Since bash _can_
prompt under Emacs, it's obviously possible; it just requires setting
up the io streams properly.

-- Stephe

reply via email to

[Prev in Thread] Current Thread [Next in Thread]