[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[help-GIFT] Problem with the Charmer applet

From: Helga Velroyen
Subject: [help-GIFT] Problem with the Charmer applet
Date: Thu, 07 Apr 2005 10:25:12 +0200
User-agent: Mozilla Thunderbird 1.0.2-1.3.2 (X11/20050324)

Guten morgen!

Since all the postings that I found here ( were in English I am writing in English, too. I am from Germany, so if it is more convenient to you you may answer in German.

I am working at the RWTH Aachen in Germany, in the research group of Prof. Ney at the chair I6 "Bild- und Sprachverarbeitung" ( I am a student worker of Thomas Deselears (, who developed also an image retrieval software. By the way: regards from Thomas to Henning :)

I tried to install and run GIFT, but I have a problem.

First, the things that I did:

- I downloaded and compiled the gift sources
- I indexed a directory containing 1000 pictures
- I downloaded the charmer package from here ( and unpacked it - I started gift using the default port and I got a lot of debug output and in the end it says:

The current configuration directory is: ######/gift/software/gift2/
Opening port 12789
TCP socket successfully initialized:7
TCP socket successfully initialized:8
Waiting for connection...

So I guess it is waiting for clients.

- then I jumped into the directory where the Charmer stuff resides. I did:

[######:~/gift/software/Charmer-0.2b$] perl
Writing applet frame file Charmer.html

[######:~/gift/software/Charmer-0.2b$] appletviewer Charmer.html

This is happening:

A grey frame is opening with a menue "Applet" in the upper left corner and "Start: applet not initialized" in the lower left corner. I tried to choose some of the menue entries but nothing happens. If I choose "reload" in the lower left corner it says "Dispose: applet not destroyed"

Besides that I get the following error in the shell:
load: class charmer/client/Charmer not found.
java.lang.ClassNotFoundException: charmer.client.Charmer
at sun.applet.AppletClassLoader.findClass(
        at java.lang.ClassLoader.loadClass(
at sun.applet.AppletClassLoader.loadClass(
        at java.lang.ClassLoader.loadClass(
at sun.applet.AppletClassLoader.loadCode(
        at sun.applet.AppletPanel.createApplet(
        at sun.applet.AppletPanel.runLoader(
Caused by: #####/gift/software/Charmer-0.2b/charmer/client/Charmer.class (No such file or directory)
        at Method)
at at at sun.applet.AppletClassLoader.getBytes( at sun.applet.AppletClassLoader.access$100(
        at sun.applet.AppletClassLoader$
        at Method)
at sun.applet.AppletClassLoader.findClass(
        ... 8 more

it obviously does not find the file /u/velroyen/gift/software/Charmer-0.2b/charmer/client/Charmer.class

when I do:
[#####:~/gift/software/Charmer-0.2b/charmer/client$] ls       
charmer                 E:\out.mrml                             

and it is right, the file is not there.

Can you give me a hint how I can make it run? I hope I provided enough information about what I did. I also have log files of the configue, make, make install procedure, in case they are relevant. the "#####" stand for my login and homedir which I also do not want to make public.

I did not find a post about the same problem in the archive (I hope I searched long enough), so I hope you can help me.

Schöne Grüße


reply via email to

[Prev in Thread] Current Thread [Next in Thread]