[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[help-GIFT] Couldn't open gift-config.mrml

From: raf
Subject: [help-GIFT] Couldn't open gift-config.mrml
Date: Fri, 9 Nov 2007 11:15:43 +1100


i'm having trouble with gnuift. it's the same trouble that
someone had and mentioned on this list three years ago
but that thread morphed into a discussion about recompiling
gift and the problem wasn't solved as far as i could tell.
i was hoping i might have more luck :)

this is on ubuntu-7.04, linux-2.6.20-15-generic,
and gnuift-0.1.14-6.2 (the package that installs on ubuntu)

i ran:

 $ /void/photos

which, after much ugly but promising output, said:

 The collection frequency is: inf
 gift-generate-inverted-file: bool
 CInvertedFileChunk::writeBinary(std::ostream&, TID, size_t)
 const: Assertion `!"collection frequency out of range"'


 Copying /home/raf/gift-config.mrml to

 Couldn't open /home/raf/gift-config.mrml:
 No such file or directory at
 /usr/X11R6/bin/ line 585

everything is owned by me.
my home directory (/home/raf) does exist.

could the non-existence of the gift-config.mrml file
be related to the "collection frequency out of range" error?

why would the collection frequency be inf?
does that mean infinite?
does that just mean that it's the first time
the collection has been scanned?
if so, how that can cause it to fail?
there has to be a first time.
if it can't work the first time,
then, by induction, it can never work :)

what can i do about this?

why would it attempt to create a gift-config.mrml file
and then immediately copy it to gift-config.mrml-old?
there's nothing old about it if it just created it?
or is it just assuming that there is an old one
and that it needs to back it up? if so, that assumption
is always false the first time it is run.

i have tried to run it again with the same results.

i tried creating an empty /home/raf/gift-config.mrml
just to get past the copy and then received this error:

Ran out of memory for input buffer at
/usr/lib/perl5/XML/Parser/ line 469, <LOCALELIST>
line 265.

which is ridiculous since i have 2GB of ram and 20GB of swap.
what can i do?


p.s. when i first ran gift, it crashed. that's terrible.
the debian manpage contained credits but no information
so only a web search helped me to discover that i needed
to run first. i later found this
crucial information in gift-guide.txt in the gnuift-doc
package so it's my own fault i suppose but, like most
people, i expect manpages to exist and to explain how to
use software.

if nobody wants to write real manpages, please at least
convert gift-guide.txt to man format and install that.

failing that, at least stop gift from crashing when it's
not initialised. it would be much nicer if there was a
warning then and there that refers to the need to initialise
and a mention of

p.p.s. i'm sorry if i sound like a whingy bastard. it's just
that i've been so thoroughly thwarted by software that i
have such high hopes for. when i heard of google's picasa, i
assumed that it let you search for images based on analysis
of the images themselves rather than pre-existing textual
attributes. when i found out that it was nowhere near as
clever as that, i was disappointed but then discovered
gnuift by chance. it sounds utterly brilliant and i am eager
to see it in action. then i was disappointed again because
it's not working for me. so forgive my whinging. i'm really
just trying to make things better/easier for everyone by
pointing out the need to make the mundane, less brilliant
parts of the software work.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]