[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[help-GIFT] Ran out of memory for input buffer at /usr/lib/perl5/XML/Par

From: Valentin JANIAUT
Subject: [help-GIFT] Ran out of memory for input buffer at /usr/lib/perl5/XML/Parser/ line 469
Date: Wed, 8 Jul 2009 12:06:27 +0800


I am looking to use GIFT, but I am having some trouble.

Firstly, I just try to use out of the box the Ubuntu package. After some problem to find the documentation and start, I finally got it. But I encounter an error :

## Ran out of memory for input buffer at /usr/lib/perl5/XML/Parser/ line 469 ##

After some research ( ), it seems that my version was too old (0.1.14) ...  So I decided to get a more recent version. I could only find 0.1.15e and 0.1.15c.

I also got different trouble with this version. I could not compile with gcc-4.3 as explain here : Firstly, I thought I can fix the error as explain in this message. But, I finally got a linking problem : ld could not find -libGIFTQuPerl. I am thinking this a problem with my configuration and about line 244 (The embedded perl interpreter ...).

Well, I decided to try to use gcc-4.1 instead of gcc-4.3. I again got some problems !! (I am thinking my directory was not so clean after all whati I did). So I tried with gift-0.1.15c, and I could success to compile it ! (With gcc-4.3)

But the joy has been short. I launched the perl script : gift-add-collection ... and got exactly the same bug !

I am thinkinng that the version of expat use on the computer does not work with gift ... So I am going te try to use the version 1.95.7 given in gift-prerequisites archive.

Before I tried to launch the script without success.

Well, I will continue to try to make it working. If I got any result, I will inform this mailing list. But if someone has any tips to help me, I am looking forward to hear him !!

Best regards,
Valentin JANIAUT
In Korea : (English)
En Corée : (Français)
GSM : +82 010 2524 1428

reply via email to

[Prev in Thread] Current Thread [Next in Thread]