[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-glpk] Solving a large LP problem

From: Samik Raychaudhuri
Subject: Re: [Help-glpk] Solving a large LP problem
Date: Thu, 15 Jul 2004 11:03:12 -0400
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040514

Hi Andrew,
This is the output I got when I solved with a considerably smaller problem.
$ glpsol --mps new.mps
load_mps: reading LP data from `new.mps'...
load_mps: name `BLANK'
load_mps: 243742 rows
load_mps: 364514 columns
load_mps: 1148311 non-zeros
load_mps: 1 right-hand side vector(s)
load_mps: 0 range vector(s)
load_mps: 0 bound vector(s)
load_mps: 932145 cards were read
lpx_simplex: original LP has 243742 rows, 364514 columns, 1148311 non-zeros
lpx_simplex: presolved LP has 90344 rows, 203072 columns, 487180 non-zeros
lpx_adv_basis: size of triangular part = 89732
umalloc: size = 3614184; malloc failed
Is this b/c I have less system memory available, or b/c of something to do with the code? How can I check if system memory is the problem.
Thanks very much for all your help.

On 7/13/2004 1:43 PM, Andrew Makhorin wrote:

The last one I solved successfully had 1453 rows and 3200 cols before
presolve in a MPS file. glpsol solved it like a snap.

Do you mean that glpsol failed on other lp instances of moderate size
(say, 2000 rows and 4000 cols)?

I also have compiled the package from scratch with the latest source code on an AIX box using gcc 3.3.3.
Any other thing you want me to check?

Glpsol successfully solved big lp instances like yours (and even
bigger), so I think it is some stupid bug. Ideally I need to know a
point in glpsol.c where it crashes. You also can try `--nopresol'

How big your mps file if it is gzipped? Can you make it available for
downloading via ftp?

Andrew Makhorin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]