[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-glpk] Suggestions for improvements

From: Shripad Thite
Subject: Re: [Help-glpk] Suggestions for improvements
Date: Mon, 26 Jul 2004 13:33:31 -0500 (CDT)

On Mon, 26 Jul 2004, Andrew Makhorin wrote:

> >If the definitions of these constants were changed so that the
> >compiler sees the symbolic names, then the error messages would be
> >much more readable and useful.  For instance, in my program I do:
> >#undef LPX_E_OK
> >const int LPX_E_OK = 200;
> >after which I get the much better error message:
> >  "Assertion `glp_lpx_simplex( lp ) == LPX_E_OK' failed."


> This is a common practice. Symbolic constants defined in library headers
> must not be redefined in the application program.

I agree.  That is why I would like the change to be made in the library
so *I* don't have to do it.

After all, the point of defining macros like LPX_E_OK is to make the
code readable.  It would be nice if assertion failure messages were more
readable too.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]