[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Help-glpk] [Fwd: Need help running GLPK code in Ubuntu server]

From: Andrew Makhorin
Subject: [Help-glpk] [Fwd: Need help running GLPK code in Ubuntu server]
Date: Fri, 07 Jun 2013 18:41:48 +0400

-------- Forwarded Message --------
From: Kazi Moyeen ul Huq <address@hidden>
To: address@hidden
Subject: Need help running GLPK code in Ubuntu server
Date: Fri, 7 Jun 2013 08:41:41 -0400

I wrote a GLPK program in Windows-Java using the current vesrion of
GLPK-java (1.0.28). It works well in windows. Now, I have to port it to
a Ubuntu server. I'm an intermediate level Ubuntu user.

When I used sudo apt-get install libglpk-java , the server installs 
libglpk-java:  1.0.1-1.1. Then when I tried to run my program ( also the
test program given in the glpk examples ) it gives the the message :

A. for  lp = GLPK.glp_create_prob();
Exception in thread "main" java.lang.UnsatisfiedLinkError:
at org.gnu.glpk.GLPKJNI.glp_create_prob(Native Method)

B. for    System.out.println(GLPK.glp_version());
Exception in thread "main" java.lang.UnsatisfiedLinkError:

Please suggest me what I should do next to make my program run in the
installed 1.0.1-1.1 version in server.( any modification required ? ) 

Thanks in advance,


for further information, I also tried these:  

A. I tried to change the repository and install the 1.0.18-1
from precise/universe amd64
Packages instead of current " lucid/universe amd64 Packages" but the
server fails to install it. It says some dependencies can't be

B. similar thing happens when I tried to manually install by
using ./configure 
then I received an error - 
configure: error: glpk.h not found
The detail error message is attached.


Attachment: glpk.h not found
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]