[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: David Miller
Subject: gnatsd
Date: Sat, 04 Sep 2004 15:11:18 -0500
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040803


A while back I had a post saying that I couldn't get gnatsweb to work. I hadn't gotten info on how to fix it until I saw a post that talked about turnning of optimization on a RedHat/Fedora machine. I didn't try it then because I knew I would be upgrading machines and OS. I now have a Fedora core 2 machine 2700 athalon. All old data was archived in a tar file. I have now tried to install gnats on the new machine. I don't know why I seem to have such a hard time with this app.

I created a user gnats. NOTE: I don't remember seeing anything that states how this should be. I created gnats with a default group of gnats and let everything else in the Fedora gui add user tool take defaults.
did an su and became root.
coppied the tar file to /usr/local/src and did a tar -xzvf gnats-4.0.tar.gz
cd to gnats-4.0
Went in to the three mentioned configure files and removed the -02 from the CFLAGS in two different locations each.
make all info
From another terminal window
su gnats
cd /usr/local/libexec/gnats
./mkdb default
It complained that it didn't have rights to create /usr/loca/com/gnatsdb. NOTE: I don't remember the manual making any comment about this kind of problem.
I created /usr/local/com and changed owner to gnats:gnats
Went back to my terminal running as gnats and tried mkdb again. This time it created the database. In a root terminal window, I went to /usr/local/etc/gnats/databases and added the info for my database. back at the gnats terminal window did ./mkdb site_manager and it created my database. I had untared my archive in a different directory and now I overwrite my database in /usr/local/com with the one from my tar file. using query-pr, etc I can work with my database. This is the way that I have always had to do it.
I am now back to where I was on my old machine.
/usr/local/etc/gnats/gnatsd.host_access I added the line
I added the following in a file called /etc/xinetd/support
service support
    disable = no
   socket_type = stream
    protocol = tcp
   wait = no
   user = gnats
   gnats server = /usr/local/libexec/gnats/gnatsd
did /etc/rc.d/init.d/xinetd restart

I can do the follow so it appears that the server works.
address@hidden gnats]# ./gnatsd -n
200 lnx101.home.loc GNATS server 4.0 ready.
USER gnats gantspr
210-Now accessing GNATS database 'default'
210 User access level set to 'listdb'
CHDB default
210-Now accessing GNATS database 'default'
210 User access level set to 'listdb'

While this is still running or after it is stopped.
telnet localhost 1529
telnet: connect to address Connection refused
telnet: Unable to connect to remote host: Connection refused

Other things I don't understand.
This is all on my machine for my development. My mail is all done with pop and snmp. I don't have the sendmail damon running. My machine is on a private network 192.168.*.* . I some times will route port 80 to my machine and give someone the IP so that they can see my webserver that I use to develop with. I would like to run gnatsweb for my own use, and may want the outside to be able to see it through port 80. If gnats is to use email it would have to be routed through my pop mail and smtp. I don't understand how to do that.
Although, I know that I have to get past the server running, but when I do.
make install CGI_DIR=/var/www/cgi-bin it puts the two .pl files and an html file in the cgi-bin directory and says your ready to go. Well I copy the html file to /var/www/html and point a browser to it and it gives me an info page. How will I get to the login and all the other gnats pages? Will the perl scripts take care of this once the damon can be connected to?

David Miller

reply via email to

[Prev in Thread] Current Thread [Next in Thread]