[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gnatsd problems with 4.0.1

From: Chad Walstrom
Subject: Re: gnatsd problems with 4.0.1
Date: Wed, 5 Jan 2005 16:24:35 -0600
User-agent: Mutt/1.5.6+20040907i

Tim Buck wrote:
> I'm trying to build gnats 4.0.1 on a FreeBSD 5.3/amd64 platform.  It
> compiles OK, but segfaults when invoked. So I built it with CFLAGS="-g
> -Wall" to get debugging symbols in the binary, but this binary doesn't
> segfault!

Hmm... I know there have been some problems recently with the gcc
compilers, libc, and 4.0.x.  I believe it has something to do with the
memcpy() handling in ./libiberty, especially when compiled with
optimizations turned on.  The suggestion has been to turn off
optimizations when you compile.

This was the reason why I tried to update the ./libiberty and ./include
directories in the CVS version of GNATS.  As you experienced, there are
build problems on the FreeBSD platform involving this upgrade.

> However, the debugging binary doesn't work correctly. Some commands
> (such as DBLS) work, but most EXPR commands return "415 invalid
> expression" (the same expressions work in gnats 4.0).

This is strange.  There were no changes to the regex code between 4.0
and 4.0.1.  Have you tested simple expressions as well as more complex
ones?  If you could share what you've tried, perhaps we can test on our
own as well.

> Since 4.0 seems to work correctly, I'm sticking with it for now.  But
> I'd like to stay current, so if you have any ideas about what's going
> on please share them! I'll be happy to provide further info as needed.

The "exploit" possibility in gnats <= 4.0 is fairly remote, if not well
neigh impossible.  Sticking with gnats 4.0 is fine, though I would like
to make things work for you in 4.0.1.

Chad Walstrom <address@hidden> 
           assert(expired(knowledge)); /* core dump */

Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]