[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

problems with emacs lisp function

From: Enrico Campanelli
Subject: problems with emacs lisp function
Date: Sat, 12 May 2001 15:38:42 +0200

hallo everybody!
I've emacs-20.4-4 on my linux redhat 6.1 system, and I tryed to define a simple lisp function to insert {} in a document with emacs in tex mode. The lisp code in the .emacs file is:
(global-unset-key "\C-d")
  (defun parentesigraffe()
  (insert "{}")
  (backward-char 1)
(define-key tex-mode-map "\C-dg" 'parentesigraffe)
The problem is that when I run emacs, I get the following error message:
"symbol's value as variable void: tex-mode-map"
The unsetting of C-d sequence works fine but C-d g doesn't.
It means that it don't understand the string "tex-mode-map". I tryed the following:
1) I tryed to put c-mode-map, lisp-mode-map but i get the same error
2) I tryed to put nothings  but I get the message that there are too few arguments
3) in the past I have had linux redhat 5.0 with emacs-20.2-4 and this lisp code worked fine. So I've reinstalled that older version of emacs but it dosen't works anymore :-(( So I've reinstalled the newer one.
4) I have given a lot of punch to my PC (.....I'm joking!!)
So, where can be the problem?  HELP me please, I'm going to destroy my PC!!!!!
Thanks a lot to all people that have read this message!!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]