[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emacs 21.2.1 slow over DSL

From: Chuck Bernard
Subject: Re: emacs 21.2.1 slow over DSL
Date: Mon, 20 May 2002 11:34:16 -0700


I have also just upgraded to 21.2.1 (also from 20.7.1).

I have a DSL line at home and work from there occasionally.   Unfortunately, I
haven't yet tried the new version of emacs from home yet.  Your comments
worry me so I will do that tonight and post the results.

For comparison sakes:

My DSL line is capped at 780kbps and I am running the above versions of
emacs on Solaris 2.7 on an Ultra 10 Sparc Station.  My connection to the office
is through a VPN box which sits on my network at home with a matching box
at the office. Nothing real state of the art anymore.   At home I'm running
the Xfree86 X-server on a 450Mhz G4 Mac running Mac OS X.


Dave Lawrence wrote:

> I recently upgraded to Redhat 7.3 which comes with emacs 21.2.1 and I've
> noticed that it runs a lot slower when I run it remotely through my DSL
> connection.  My experience with older versions of emacs (20.7.1 for example)
> was that it was a bit slow to open emacs remotely, but once it was open, it
> ran acceptably fast.  I just did an experiment where I opened a small file
> with 20.7.1 and with 21.2.1 remotely.  It took 16 seconds for 20.7.1 to open
> the file and 37 seconds for 21.2.1 to open the same file.  The real problem
> for me is that even after the emacs window is up, it seems to take a long time
> to do every operation.  For example, I hit c-x c-f to open a second file...
> it took 5 seconds for 21.2.1 to prompt me for the new file name; it was under
> a second for 20.7.1.
> Is this slowness due to the fringes and toolbars that I hear so much about?
> If so, I definitely think there should be an option to disable them.  Or is
> there something else going on? If so is there a way to fix it? (maybe a
> set-variable dsl-really-slow nil command?  ;) )
> Thanks for any help.
>                           Dave
> PS - I have tried to get around this problem using tramp so I don't have to
> run emacs remotely, but I'm having troubles with that too.  It waits 60 
> seconds
> and then says it never got a password or shell prompt even though it did get
> a shell prompt.  I can't say I've read through all of the manual for tramp
> yet, so I might not have it configured quite right.  All I've done it set up
> ssh/scp to not require a password and add the following to my .emacs file:
> (add-to-list 'load-path "~/emacs/tramp/lisp/")
>      (require 'tramp)
> (setq tramp-default-method "scp")
> Any suggestions about what I'm doing wrong with tramp would be appreciated 
> too,
> although I still think there should be a way to run emacs faster remotely
> (without unsetenv DISPLAY).
> _______________________________________________
> Help-gnu-emacs mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]