[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Loading local .emacs from remote machine

From: Kai Großjohann
Subject: Re: Loading local .emacs from remote machine
Date: Wed, 05 Feb 2003 13:51:58 +0100
User-agent: Gnus/5.090015 (Oort Gnus v0.15) Emacs/21.3.50 (i686-pc-linux-gnu) writes:

> Kai Großjohann at 18:30 (UTC+0100) on Tue, 4 Feb 2003 said:
> I was following the documentation.  What would be the way to load a 
> *.texi file?

It doesn't make sense to "load" a *.texi file.  You can convert it to
info format with M-x texinfo-format-buffer RET or with the external
makeinfo program.  (Though the latter doesn't work in this case, of

After this, you'll have *.info files which you can look at with C-u
C-h i.

Where in the documentation did you find instructions to load the
*.texi files?  I couldn't see it.  I want to correct it...

> = > Subsequently doing "M-x makeinfo-buffer" yeilds "[No match]".
> = 
> = I think it's M-x texinfo-format-buffer RET...
> Again, the command I used was directly from the docs.

Got to look at the docs again, to correct them.  [time passes]  Ah,
found it, and corrected it.

> = Yes, I also guess that the shell prompt wasn't recognized.  Lessee
> = now, what is the default value of tramp-shell-prompt-pattern?  Hm.
> = It should have matched this prompt.
> = 
> = So I'm somewhat confused.
> I don't know enough about this even to be confused....  8\
> = 
> = Could you put (setq tramp-verbose 10) and (setq tramp-debug-buffer t)
> = in ~/.emacs and try again and show me the *tramp/foo* buffer in
> = addition to the *debug tramp/foo* buffer?
> = 
> = Also, it would be good to do M-x toggle-debug-on-quit RET before
> = trying, then C-g will give you a backtrace.  Please send it, too.
> = 
> = Oh, and removing tramp.elc before starting Emacs will give a prettier
> = backtrace.
> Did all this.  Then tried to open a file on the same machine as before.

> $ # Setting shell prompt
> $ PS1='
> ///»¢ò ;YÖv­  éü­
> '; PS2=''; PS3=''

Now we're talking!  It's the bogus md5 invocation.  Whee.  I believe
this is fixed in the development sources already, so let me put out a
new version.

You could fetch the CVS version to test it, if you like.

> A string in elisp must be some really strange thing.
> (add-to-list 'tramp-shell-prompt-pattern "abc")
> also gives the same error.  It seems that everything and anything I put into
> the third arg is a listp.  It's a shame elisp is so obtuse.  I'd like to learn
> it so's to do some helpful work on emacs.  Several times I've tried to do
> simple things in elisp, following books and tutorials, but never had any
> progress with it.  Maybe I need to be dyslexic.  :)

In Lisp, a general type is sequence.  Lists are one subtype of
sequence, and vectors are another.  Strings are vectors of characters.

add-to-list can only add to lists, not to arbitrary sequences.

Does this make sense?

A turnip curses Elvis

reply via email to

[Prev in Thread] Current Thread [Next in Thread]