[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Loading local .emacs from remote machine

From: gebser
Subject: Re: Loading local .emacs from remote machine
Date: Wed, 5 Feb 2003 10:17:12 -0500

Kai Großjohann at 13:51 (UTC+0100) on Wed, 5 Feb 2003 said:

= writes:
= > Kai Großjohann at 18:30 (UTC+0100) on Tue, 4 Feb 2003 said:
= >
= > I was following the documentation.  What would be the way to load a 
= > *.texi file?
= It doesn't make sense to "load" a *.texi file.  You can convert it to
= info format with M-x texinfo-format-buffer RET or with the external
= makeinfo program.  (Though the latter doesn't work in this case, of
= course...)

Hmmm....  I loaded tramp.texi into a buffer, then did "M-x
texinfo-format-buffer RET" and it halted midway with the cursor on a
line saying "@macro trampver{}" and with the comment "@macro is not
handled by texinfo".

= After this, you'll have *.info files which you can look at with C-u
= C-h i.

Did this and was prompted in the minibuffer for a filename (with the
current .../tramp/texi/ directory provided.  I looked at the directory
listing and found,, and and quite
arbitrarily picked  This then brings up the info file and
it seems to work.  I did the same again, but this time specifying this wasn't so good.  Hitting SPACE would page down fine,
but if I hit 'm' I was prompted for a menu item, then typed in the first
few chars of "Inst", hit TAB, it completed to "Installation"
successfully, but then when I hit ENTER, it beeped and said in the
minibuffer "No such anchor in tag table or node in tag table or file:
Installation".  Didn't have this problem with

= Where in the documentation did you find instructions to load the
= *.texi files?  I couldn't see it.  I want to correct it...

It's on the web at <> under
"Node:Installation".  The tramp tarball I got didn't have any
installation instructions.  Well, not until just now when, with your 
help, I got a working info file... sort of.

If, from the command line, I do "info tramp", info comes up, but says 
"No menu item `tramp' in node `(dir)Top'".

If you first warn installer-wannabees to use 'q' to quit/exit "info", 
you could hip them to the install instructions by having them or 
something run "cd ./texi; info --file --node Installation", 
this to bring up your instructions.

= > = > Subsequently doing "M-x makeinfo-buffer" yeilds "[No match]".
= > = 
= > = I think it's M-x texinfo-format-buffer RET...
= >
= > Again, the command I used was directly from the docs.
= Got to look at the docs again, to correct them.  [time passes]  Ah,
= found it, and corrected it.

The webpage still says:

"Something similar can be done to create the info manual. Just change to
directory ~/emacs/tramp/texi and load the tramp.texi file in Emacs. Then
press M-x makeinfo-buffer <RET> to generate"

This is the "Tramp Manual" at <>.

= ...
= >...
= > = 
= > = Could you put (setq tramp-verbose 10) and (setq tramp-debug-buffer t)
= > = in ~/.emacs and try again and show me the *tramp/foo* buffer in
= > = addition to the *debug tramp/foo* buffer?
= > = 
= > = Also, it would be good to do M-x toggle-debug-on-quit RET before
= > = trying, then C-g will give you a backtrace.  Please send it, too.
= > = 
= > = Oh, and removing tramp.elc before starting Emacs will give a prettier
= > = backtrace.
= >
= > Did all this.  Then tried to open a file on the same machine as before.
= > $ # Setting shell prompt
= > $ PS1='
= > ///»¢ò ;YÖv­        éü­
= > '; PS2=''; PS3=''
= Now we're talking!  It's the bogus md5 invocation.  Whee.  I believe
= this is fixed in the development sources already, so let me put out a
= new version.

Cool!  I really like progress.

= You could fetch the CVS version to test it, if you like.
= > A string in elisp must be some really strange thing.
= >
= > (add-to-list 'tramp-shell-prompt-pattern "abc")
= >
= > also gives the same error.  It seems that everything and anything I put into
= > the third arg is a listp.  It's a shame elisp is so obtuse.  I'd like to 
= > it so's to do some helpful work on emacs.  Several times I've tried to do
= > simple things in elisp, following books and tutorials, but never had any
= > progress with it.  Maybe I need to be dyslexic.  :)
= In Lisp, a general type is sequence.  Lists are one subtype of
= sequence, and vectors are another.  Strings are vectors of characters.
= add-to-list can only add to lists, not to arbitrary sequences.
= Does this make sense?

Yes, thanks much.  It's not enough for me write all those gorgeous
emacs apps I've been hankering to do, but, as said, I like progress.

I think I remember reading in a book or two that every|some (?) data
type(s) in elisp contain(s) an element (including perhaps null... or
nil... I forget, except there's a difference... I think) *and* the
implication of a subsequent such element-- hence, a sequence.

That a string is a vector of characters (delimited by double quotes,
yes?) is simple enough.  Is it also possible to have a list of
characters?  If not, why not?  If so, how would it be structurally or
functionally different or handled differently from a string?

Kai, thanks for your help and for the work you've done on this package.  
Much appreciated.


Happy Gui-Wei 4700

reply via email to

[Prev in Thread] Current Thread [Next in Thread]