help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: help:update to new version 21.2.1


From: gebser
Subject: Re: help:update to new version 21.2.1
Date: Fri, 21 Feb 2003 10:31:33 -0500

Kai Gro├čjohann at 16:20 (UTC+0100) on Fri, 21 Feb 2003 said:

= Tom Hu <tomhu@cisco.com> writes:
= 
= > I update my emacs from 19.34 to 21.2.1. My init .emacs does not work
= > correctly now.
= >
= > The first suspect is that when I edit a file, I got an error:
= 
= What kind of file?  If it is a C file, look for C mode customizations
= in your .emacs file.
= 
= > file mode specification error: (error "Cannot recognize major version
= > number: 21).
= >
= > All my c-style format are lost. setnu (set number line) is lost too.
= 
= Another alternative is to do the binary search dance: comment out the
= second half of .emacs, see if the error is still there.  If the error
= is still there, comment out more.  If the error is gone, re-enable
= some commented-out sections.  Repeat until you get to the troublesome
= statement.

You could also look at your *Messages* buffer.  It will point out where 
the failure happened.  Then you can fix it or comment it out and try 
again.

ken




reply via email to

[Prev in Thread] Current Thread [Next in Thread]