[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ssh in emacs shell in OS X

From: Kai Großjohann
Subject: Re: ssh in emacs shell in OS X
Date: Thu, 28 Aug 2003 22:00:46 +0200
User-agent: Gnus/5.1003 (Gnus v5.10.3) Emacs/21.3.50 (gnu/linux) (david) writes:

> After some Googling, I tried to get ssh working from an emacs shell.
> This also fails.  After typing M-x shell and receiving a bash shell, I
> type:
>         bash-2.05b$ ssh me@host
> and emacs replies with
>         Pseudo-terminal will not be allocated because stdin is not a
> terminal
>         ssh_askpass: exec(/sw/lib/ssh-askpass): No such file or
> directory
>         Write failed: Broken pipe
> I get a corresponding error when I use the OS X default ssh. It looks
> for askpass in a different directory and doesn't find it there,
> either.

Ah, the infamous process-connection-type problem.  Under OS X,
process-connection-type is set to nil, but then Tramp doesn't work.
I think that some people have tried setting it to t, and at least
their computer didn't blow up.  But I don't know what other bad side
effects this setting had.

Another possibility might be to use the sshx method.  It invokes "ssh
-t -t".  The double "-t" argument is an undocumented ssh-on-Windows
(mis?)feature to force it to alloc a pty.  Maybe it also works on OS X?
Two cafe au lait please, but without milk.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]