help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Fatal error when trying to run emacs 21.3 on win2k


From: Harald Maier
Subject: Re: Fatal error when trying to run emacs 21.3 on win2k
Date: Sat, 14 Feb 2004 17:30:25 +0100
User-agent: Gnus/5.110002 (No Gnus v0.2) Emacs/21.3.50 (gnu/linux)

address@hidden (David) writes:

> I'm trying to upgrade from emacs 20.7 to emacs 21.3. (BTW, it's not
> clear to me if version 21.3 is valid -- according to
> http://ftp.gnu.org/pub/gnu/windows/emacs/21.3/emacs-21.3-fullbin-i386.tar.gz.back-RSN.README
> from 23Oct2003 it's not valid, but nevertheless the files appear
> ready for download at
> http://ftp.gnu.org/pub/gnu/emacs/windows/emacs-21.3-fullbin-i386.tar.gz
> from 26Jan2004). I downloaded from the abovementioned address, ran
> gunzip-1.2.4-i386, tar-1.11.2a, and addpm. All seemed to execute
> okay.  I now have 2 subdirectories in C:\emacs, emacs-20.7 and
> emacs-21.3.  When I try to run emacs.exe from
> C:\emacs\emacs-21.3\bin, I get an "Emacs Abort Dialog" window
> stating that a fatal error has occured.  Then I get a "Program
> Error" window stating that emacs.exe has generated errors and will
> be closed by Windows.

Yes, you are right, the current version of emacs on the ftp.gnu.org
server has the described problem. The binaries will be replaced but
this can take some time. Please look for other downloads. The places
are posted here. E.g.:

http://www.google.de/groups?hl=de&lr=&ie=UTF-8&oe=UTF-8&selm=u65f6tiog.fsf%40noniq.at

If you want to compile emacs by yourself you need either MSVC or you
can do it with cygwin gcc. But for emacs-21.3 and for the latest
cygwin gccs you need to a patch. This patch is too missing in the
above mentioned version on ftp.gnu.org. You may find additional info
here for under:

   address@hidden

Harald


reply via email to

[Prev in Thread] Current Thread [Next in Thread]