help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: ansi/vt100 cursor issue


From: Barnaby Falls
Subject: RE: ansi/vt100 cursor issue
Date: Wed, 19 May 2004 00:51:25 -0700

Date: 19 May 2004 08:49:41 +0200
From: Eli Zaretskii <address@hidden>
Subject: Re: ansi/vt100 cursor issue
To: address@hidden
Message-ID: <address@hidden>

> From: "Barnaby Falls" <address@hidden>
> Date: Tue, 18 May 2004 13:25:32 -0700
>
> I run emacs 21.2 on Linux and want to get the color syntax highlighting and > all that. When I run with TERM=vt100 I get a gray and bold highlighting and
> the cursor appears where it should.

That's because vt100 doesn't support colors.

> However, if I run with TERM=ansi, I get
> the cool color syntax highlighting but the cursor is all the way in the top > right corner of the window and some text is wrapped and starts at the end of
> the previous line.

Sounds like "ansi" does not accurately describe your terminal: the
cursor motion commands are incorrect.

> This all just regular text emacs, no X. Any ideas on how
> to correct this so I can get emacs working with TERM=ansi?

What terminal do you _actually_ use?  You need to point TERM to the
name of that terminal, not some more-or-less arbitrary name like
"ansi".

I use the SSH Secure Shell Client (ssh.com). It allows you to set the terminal answerback type, I have it set to `ansi'. But I just removed that setting and logged on again and got the following:
$ echo $TERM
vt100

So I guess I'm trying to get colors in a terminal application (SSH) that cannot handle it. Seeing this, I now tried this from a regular XP command prompt and ran ssh to connect to the computer and got the following:
$ echo $TERM
cygwin

The colors show up nicely and I think I see what you mean by using some arbitrary name for the TERM setting. So it looks like the SSH shell client I am using doesn't support ansi. Thanks alot for clearing that up.

Barnaby. . .

AFAIK, GNU/Linux systems have TERM set to the right string
automatically, so you shouldn't need to change that yourself.  What is
the value of TERM when you log in with an empty .login and shell
startup files?






reply via email to

[Prev in Thread] Current Thread [Next in Thread]