[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ido.el, usability when saving a new file

From: Phillip Lord
Subject: Re: ido.el, usability when saving a new file
Date: Thu, 08 Jun 2006 11:54:42 +0100
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.50 (windows-nt)

>>>>> "KFS" == Kim F Storm <> writes:

  >> which is fine if it's where you want it to go. But otherwise, you
  >> have to delete "theNewFileToSave.txt" and then navigate to the
  >> directory that you want.
  >> When you get there, say
  >> ~/scratch
  >> you now have to type the file name in again (if you select
  >> ~/scratch alone, ido asks you if you want to overwrite the file
  >> which already exists.

  KFS> When I use C-x C-w with ido, it gives me the option to select
  KFS> the directory where to save the file so I just navigate to the
  KFS> desired target directory, and press C-j.  Ido then saves the
  KFS> file with the current file name [unless I have entered another
  KFS> name].

  KFS> So doing what you want is trivial with ido.

Hmmm. This is not the behaviour that I an getting. I have just tried
this with emacs -Q. I am getting the following...

1) Open ~/documents/books.txt
2) C-xC-w   offers ~/documents/books.txt
3) navigate to ~/scratch
4) C-j to save (I didn't know C-j before so I have learnt something
5) File is saved in ~/documents/books.txt

I am guessing that this is, then, a bug. Incidentally, this does
reset the default-directory for books.txt buffer to ~/scratch

  KFS> In general, if you want to find the current file in another
  KFS> directory, you can do it with the following keystrokes:

  KFS>  C-x C-f - ido-find-file <navigate to target directory> C-w -
  KFS>  insert current file name (C-w C-w may be needed) RET or C-j -
  KFS>  open file.

Okay, I will try these out.

  KFS> If you have entered a file name, but realize that it is not in
  KFS> the current directory, you can "push it away" and navigate to
  KFS> another location like this:

  KFS>  C-x C-f - ido-find-file xyzzy - enter a file name M-b or M-v -
  KFS>  push entered text or first matching item navigate using M-BS
  KFS>  and M-SPC M-f - pop C-j or RET -

  >> Anyone got any suggestions. Am I missing something?

  KFS> And of course, you can just M-x cd before using C-x C-w...

yep, I've worked this out now and it works very well; except if you
sending lots of emails with attachments from the same directory --
then you have to use M-x cd in the *Group* buffer.

So, it looks like there is a bug here somewhere. I am using the CVS
version as supplied by EmacsW32. As I said, I've run this using -Q,
although I have had to do

(setq tramp-default-method "ssh") to fix a recursive load bug that I
was having.

I shall try updating my emacs and see if that changes things. 



reply via email to

[Prev in Thread] Current Thread [Next in Thread]