[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gnuserve switches to the old Emacs window but does not open the file

From: Bernhard Koenig
Subject: Re: gnuserve switches to the old Emacs window but does not open the file
Date: Sat, 10 Jun 2006 00:15:14 +0200

----- Original Message -----
Sent: Friday, June 09, 2006 11:42 PM
Subject: Re: gnuserve switches to the old Emacs window but does not open the file

Bernhard Koenig wrote:
> ----- Original Message -----
>     *From:* Lennart Borgman <>
>     Bernhard Koenig wrote:
>     > The problem shows up sometimes but not all the times, I couldn't
>     quite
>     > figure out when it does and when not. E.g. if I click two files
>     with
>     > gnuclientw
>     > in a very short interval, then it usually works. The longer the
>     > interval, the more
>     > likely the problem occurs.
>     There are several gnuserve packages. Please use the latest from
>     EmacsW32
>     ( or Guy
>     Gascoigne-Piggford
>     website.
>     There is a name clash between the package server.el and gnuserv.el in
>     the old packages.
> I downloaded the whole package
> Emacs-22-CvsP060314-EmacsW32-1.00.exe from your link above.
> But the problem seems to be the same. The problem happens if I open a
> file with gnuclientw,
> then e.g. browse through directories for a while, then open another
> file with gnuclientw and
> the old emacs windows pops up but does not load the second file.
> The new thing with this version is that after closing the emacs
> window, I get the message:

> unable to read the reply from the server
> WSAGetLastError=10054
> It doesn't seem to be a firewall problem though since I also tried it
> with the firewall switched off.

Strange, I have never seen this. But did you remove everything about
gnuserv from your startup files (.emacs etc)? If you use the EmacsW32
setup then this starts Emacs and gnuserv automatically for you when you
click a file for example. If you have not removed everything about
gnuserv, could you please try that?

(I guess you downloaded Emacs-22 CvsP060608-EmacsW32-1.03.exe?)
You're right, I downloaded Emacs-22 CvsP060608-EmacsW32-1.03.exe but note that
on the link reads Emacs-22-CvsP060314-EmacsW32-1.00.exe.
Previously, I still had gnuserv in my .emacs file. Now I removed gnuserve from .emacs and if
I type "gnuclientw filename.txt" then emacs opens but does not load any file (now even if it's the
first file to open).
Starting emacs (in whichever way) now almost immediately leads to the following message:
"Started Emacs and tried to connect during 60 seconds. Connection still fails. Are you sure gnuserve.exe
is started by Emacs? WSAGetLastError=10061."
Maybe there is a problem with my setup, but I simply used the install wizard until finish (and I'm really
working with the new version now). Is there anything I might have forgotten in the setup?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]