help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Error happened to my Emacs when I configure the ECB for Emacs 21.4


From: mclos . lin
Subject: Re: Error happened to my Emacs when I configure the ECB for Emacs 21.4
Date: 15 May 2007 22:34:14 -0700
User-agent: G2/1.0

On May 15, 11:50 am, "Lennart Borgman (gmail)"
<address@hidden> wrote:
> address@hidden wrote:
> > Does anybody let me know what happened to my Emacs? I run the Emacs
> > under OpenBSD 4.1. The Emacs' version is 21.4
>
> > My emacs for ECB configuration is following:
>
> > ;; Configure ECB
> > (add-to-list 'load-path "~/.emacs.d/cedet-1.0pre3/eieio/")
> > (add-to-list 'load-path "~/.emacs.d/cedet-1.0pre3/semantic/")
> > (setq semantic-load-turn-everything-on t)
> > (setq semantic-idle-scheduler-idle-time 432000)
> > (add-to-list 'load-path "~/.emacs.d/cedet-1.0pre3/speedbar/")
> > (add-to-list 'load-path "~/.emacs.d/ecb-2.32")
> > (require 'ecb)
> > (require 'ecb-autoloads)
>
> > The debug message:
>
> > Debugger entered--Lisp error: (void-function case)
> >   (case system-type (cygwin32 (quote cygwin)) (windows-nt
>
> Looks like there is a missing
>
>    (eval-when-compile
>      (require 'cl))
>
> somewhere.- Hide quoted text -
>
> - Show quoted text -

Is it said that I shouldn't compile the ECB?

BTW, would you mind to let me know where to put the (eval-whe-compile
(require 'cl)) in the *.el files?

Thank you



reply via email to

[Prev in Thread] Current Thread [Next in Thread]