[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

I can't turn off colors in emacs!

From: Schlake
Subject: I can't turn off colors in emacs!
Date: Tue, 9 Oct 2007 13:00:52 -0600

A computer center I use frequently upgraded their RedHat boxes, and
now emacs claims to be 22.0.990.1.  All of a sudden emacs gas gone
wacky with colors appearing for all kinds of words and symbols
rendering it pretty much unusable.  I've tried a variety of things to
get it fixed, but I have to admit defeat.

Starting emacs with --color=no is a resounding failure.  There are
absolutely no colors anymore, but text that would be colored is now
boldfaced and inversed, making it even more unusable than emacs with
colors.  Plus, with that option I can't use colors if/when I want

Another possible solution is (global-font-lock-mode nil).  It does
most of what I want.  Colors go away in most buffers, and I don't get
boldfaced or inversed video anymore!  This is a great solution except
for the part about "most buffers".  The minibuffer is the worst
offender of buffers that ignore the global font lock mode, but compile
mode does as well.  I'm sure there are others which I haven't
discovered yet.

I tried messing with font-lock-maximum-size, as well as making a mode
hook to turn off font lock mode in all modes, but neither met with
success defeating font lock mode in the minibuffer.

Previous pain with font lock mode from 2003 was initially solved by
making a huge list of set-face-foregrounds to keep all the modes from
being anything other than white.  I dislike this solution a lot, and
would rather not have to resort to it again.  I fixed the 2003 font
lock problems with (setq inhibit-default-init t), but that doesn't
work anymore.

Does anyone know how to disable font lock mode?

-- Schlake

This is my gmail account, I can also be reached at address@hidden, if
the TCC is working.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]