[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Emacs + cscope (xcscope.el)

From: Iakie
Subject: Emacs + cscope (xcscope.el)
Date: Thu, 11 Oct 2007 10:52:38 -0700
User-agent: G2/1.0

Hi there:

Can anyone give me some tips on using cscope and emacs?

I was able to load xcscope.el from cscope package. However, whenever i
tries to use it, it says it finds nothing.

I edited my .emacs like this:

(load-file "/usr/share/emacs/site-lisp/xcscope.el")
(require 'xcscope)

Then, I untar-ed linux kernel in my home folder, under which I ran
cscope to generate search database. And I tried to edit some files


address@hidden:~/linux-source-2.6.22$ cscope -R -q -b
address@hidden:~/linux-source-2.6.22$ emacs kernel/time.c

When I tried to find symbol definition using C-c s d, it returns no
matched result


Finding symbol: tv_nsec

Database directory: /home/me/linux-source-2.6.22/
cscope: no source files found


Search complete.  Search time = 0.01 seconds.

Can someone tell me what I did wrong?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]