[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

shell, eshell and sql-postgres no prompt [LONG]

From: Bob Nelson
Subject: shell, eshell and sql-postgres no prompt [LONG]
Date: Tue, 12 Feb 2008 00:06:46 -0600
User-agent: KNode/0.10.4

Here's the essence of the problem:

Any and ALL processes started in eshell, shell or any of the SQL
interactive modes do NOT show the application's command prompt. The
process works fine otherwise. This is most evident with ``psql'' but
happens with anything that would otherwise have a prompt (such as

1). To this point of my investigation, I've tried setting TERM to
    ``dumb'', ``cygwin'', ``vt100'' and ``linux''.

2). Thus far, I've tried setting the SHELL and shell-file-name to
    ``bash'', ``ash'', ``CMD.EXE', ``COMMAND.COM'' and ``cmdproxy''.

3). The problem occurs with emacs-22.1 compiled against MSVC and MinGW.
    It also happens with the ``fullbin'' package from the GNU FTP site.

4). It happens whether I launch emacs from within Cygwin or from the
    native Windows CMD.EXE processor. It happens regardless of whether
    ``runemacs'' or ``emacs'' is the command used to invoke emacs.

5). It also happens when running under ``rxvt'' as well as the Cygwin
    bash shell.

6). Setting CYGWIN=tty also makes no difference.

7). Whether or not ``setup-cygwin.el'' is loaded also makes no

I primarily work under Solaris and Linux, so this Windows environment
is foreign to me and I've likely botched something. Here's information
about the system.

a). GNU Emacs 22.1.1 (i386-msvc-nt4.0.1381) of 2008-02-09 on DUCKY
b). Windows NT 4 SP 6a

Now, here's a ``shell'' session showing the problem illustrated with
PostgreSQL's monitor. Note that everything works but that there's no
welcome banner nor the expected ``test#'' prompt (as there is in Linux
and Solaris). The only interactive program that I've found that prompts
under either eshell or shell is ``units'' as this trace shows:

============================= [ BEGIN shell ] ==========================

Mon Feb 11 22:54:32 CST 2008

~>uname -a
CYGWIN_NT-4.0 ducky 1.5.25(0.156/4/2) 2007-12-14 19:21 i686 Cygwin

~>echo $SHELL

~>echo $TERM

~>psql --version
psql (PostgreSQL) 8.2.6
contains support for command-line editing

~>psql -l
              List of databases
      Name       |     Owner     | Encoding
 bnelson         | bnelson       | SQL_ASCII
 booktown        | bnelson       | SQL_ASCII
 mere_mortals    | bnelson       | LATIN9
 momjian         | bnelson       | SQL_ASCII
 movies          | bnelson       | LATIN9
 nlcc            | bnelson       | SQL_ASCII
 origins_db      | bnelson       | SQL_ASCII
 playpen         | bnelson       | SQL_ASCII
 postgres        | postgres      | SQL_ASCII
 practice        | bnelson       | SQL_ASCII
 reference_files | bnelson       | SQL_ASCII
 sql_nutshell    | bnelson       | SQL_ASCII
 template0       | postgres      | SQL_ASCII
 template1       | postgres      | SQL_ASCII
 test            | bnelson       | SQL_ASCII
 training        | bnelson       | LATIN9
(16 rows)

~>psql test
select version();
 PostgreSQL 8.2.6 on i686-pc-cygwin, compiled by GCC gcc (GCC) 3.4.4
(cygming special, gdc 0.12, using dmd 0.125)
(1 row)



~>psql test
select version();
 PostgreSQL 8.2.6 on i686-pc-cygwin, compiled by GCC gcc (GCC) 3.4.4
(cygming special, gdc 0.12, using dmd 0.125)
(1 row)


1989 units, 71 prefixes, 32 nonlinear units

You have: 100 yards
You want: feet
        * 300
        / 0.0033333333
You have:


Process shell finished

============================= [ END shell ] ==========================

reply via email to

[Prev in Thread] Current Thread [Next in Thread]