[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: colour highlighting problem on major modes

From: Yo Sato
Subject: Re: colour highlighting problem on major modes
Date: Sat, 16 Feb 2008 18:44:12 +0000

Thanks for your reply Peter, the problem has been solved with your
suggestion, or, nearly.

Indeed global-font-lock seems to have been the main culprit, and with
this mode on all the colours have come back!! -- so I thought. However
I then realised the prolog mode I mentioned, which *was* working --
installed on the home directory and loaded with .emacs (as below) --
has gone... Rather, I need to invoke the mode manually now. Also, I
lost the mouse wheel functionality, though it was easy to recover it
by adding 'wheel-mouse' in .emacs.

I'm puzzled by this apparent incompatibility -- only on one machine
--- between the modes loaded from a default directory and the ones
loaded from somewhere else. It seems that only one or the other sets
seem to work at one time. I don't understand either why the same
.emacs does not work only for this particular installation.

I put the line to switch the global-font-mode on (as you suggested) at
the beginning of the .emacs file. I tried various places but the
results were the same.

Not a big problem anymore but I would appreciate some explanation for
the above phenomenon.


This is the bit that loads prolog.el. Nothing unusual I guess.

(setq load-path (cons "~/emacs.lib/" load-path) ) % this is where
prolog.el resides
(autoload 'run-prolog "prolog" "Start a Prolog sub-process." t)
  (autoload 'prolog-mode "prolog" "Major mode for editing Prolog programs." t)
  (setq auto-mode-alist (append '(("\\.pl$" . prolog-mode))

On 16/02/2008, Peter Dyballa <address@hidden> wrote:
> Am 15.02.2008 um 17:00 schrieb Yo Sato:
> > What could I be missing?
> Maybe:
>         (cond ((fboundp 'global-font-lock-mode)
>            ;; Turn on font-lock in all modes that support it
>            (global-font-lock-mode 1)
>         ;   (setq font-lock-multiline 'undecided')
>            (setq jit-lock-stealth-verbose t)
>            (setq jit-lock-mode t)
>         ;   (setq jit-lock-stealth-load 80)
>            ;; Maximum colors
>         ;   (setq font-lock-maximum-decoration t)
>           (setq font-lock-maximum-decoration '((tex-mode . 2) (latex-mode .
> 2) (t . t)))
>         ))
> --
> Greetings
>    Pete
> Clovis' Consideration of an Atmospheric Anomaly:
>          The perversity of nature is nowhere better demonstrated
>          than by the fact that, when exposed to the same atmosphere,
>          bread becomes hard while crackers become soft.

Yo Sato wrote:

Hi all,

I recently switched to a different distribution of linux (FC6) and
installed emacs (ver 21.4) and encounter this problem: the colour
coding doesn't work (all black and white) for most major modes,
inlcuding TeX, lisp, html, etc. I say 'most' because there is one mode
that somehow works: the prolog major mode *installed in my home
directory* (not bit-compiled). This mode (prolog.el) is the only file
loaded from the home dir by .emacs.

With other machines with different distributions, with the same .emacs
file, it is working okay. The other functionalities of the above major
modes, as far as I can see, seem to be working okay.

What could I be missing? Any help would be appreciated: I might well
be rather cursory in the above description, being not sure what more
info I should provide, which I'd be happy to provide of course.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]