[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Tramp and BusyBox problem?

From: Mats Löfdahl
Subject: Re: Tramp and BusyBox problem?
Date: Sun, 15 Mar 2009 22:23:29 +0100
User-agent: Thunderbird (X11/20090105)

Michael Albinus wrote:
Mats Löfdahl <address@hidden> writes:

That's another problem. I would need Tramp traces now. Please apply

(set tramp-verbose 6)

and rerun your test. Afterwards, send the *debug tramp/scp address@hidden
The buffer is called *tramp/scp address@hidden, without the "debug"
part, at least I guess this is what you need:

Sorry, typo. I meant

(setq tramp-verbose 6)

And I still need the *debug ...* buffer.


Another weird thing: The above is from connecting to root@ the
NAS. I've now installed bash on it and use that as my shell when I log
in as an ordinary user. This works but the dired buffer looks weird,
there are some codes surrounding the file names that I guess should
have been stripped at some point.

Here's an extract:

  drwxr-xr-x   21 root     root         4096 Mar  9 00:41 .
  drwxr-xr-x   21 root     root         4096 Mar  9 00:41 ..
  -rw-r--r--    1 root     root            3 Aug 18  2004
  -rw-r--r--    1 root     root            0 Feb 23 21:55
  -rw-------    1 root     root         1024 Aug 18  2004 .rnd
  -rw-r--r--    1 root     root            2 Mar  9 23:16
  drwxr-xr-x    2 root     root         4096 Feb 23 21:54 bin
  drwxr-xr-x    3 root     root        12288 Feb 23 21:55 dev
  drwxr-xr-x   10 root     root         4096 Mar 13 23:51 etc

The non-ascii characters are represented as "^[" in the dired buffer
but may not have survived the mouse copy to thunderbird.

Her I need the debug buffer as well. Maybe you can run both constellations?

It was different this time. When I connected as mats (bash), I first got the same uname error message as for root (BusyBox). But I knew that it _had_ worked, so I tried again and got the ugly dired buffer.

So I did the same experiment with root in a fresh instance of emacs. This generated the uname error but did _not_ work at the second attempt.

The debug buffers from the two sessions are here: - root/BusyBox - mats/bash

reply via email to

[Prev in Thread] Current Thread [Next in Thread]