[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

desktop abends after first buffer loads

From: Tom Roche
Subject: desktop abends after first buffer loads
Date: Mon, 28 Jun 2010 17:37:19 -0400
User-agent: GNU Emacs (x86_64-pc-linux-gnu, GTK+ Version 2.18.0)

summary: on starting emacs with desktop enabled, the first saved
buffer opens, and I get the local-variables prompt, then

> Wrong type argument: arrayp, nil

and no further buffers open. How to fix?


For several months I have been running GNU Emacs via ubuntu
karmic package=emacs-snapshot-gtk: 

$ lsb_release -ds
Ubuntu 9.10
$ uname -rv
2.6.31-22-generic #60-Ubuntu SMP Thu May 27 02:41:03 UTC 2010
$ emacs-snapshot-gtk --version
GNU Emacs

which I run via

$ emacs-snapshot-gtk --debug-init

For many years, I have been running emacs with desktop. Until this
afternoon, desktop was working. This afternoon, I added a new
file/buffer to my desktop and closed emacs. When I reopened emacs, I
got the usual local-variables prompt

> Please type y, n, or !, or C-v to scroll:

and typed '!' as usual. Unusually, I got the response

> Wrong type argument: arrayp, nil

and no further buffers opened. (And I did not get kicked into the
debugger, the message was only displayed in the minibuffer.) I
immediately `kill -9`ed emacs and copied the desktop file to a backup.
I tried copy/modifying the desktop file to remove the first, second,
and first 2 buffers from the list, but no change: first buffer loads,
then no more. How to fix or debug?

TIA, Tom Roche <>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]