[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: git mergetool again

From: Andrea Crotti
Subject: Re: git mergetool again
Date: Fri, 13 Aug 2010 21:43:12 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.2 (darwin)

Andrea Crotti <> writes:

> I really have to solve this before I go completely insane :D
> It's more a problem of git but could make life easier to many emacs
> user, so I think it's not offtopic.
> Anyway I like emerge and it would be nice to use it to solve conflicts
> with git.
> Now the default configuration for me is really bad, because it opens a
> new emacs, loads the WHOLE configuration and in short doesn't work at
> all!
> So I read again the doc and ended up with something like
> [mergetool "mymerge"]
>       cmd = 'exec /Applications/ -e 
> \"(ediff-files (getenv \"LOCAL\") (getenv \"MERGED\") (getenv \"REMOTE\"))\"'
> [merge]
>       tool = mymerge
> after trying all possible easier solutions.
> but now way it doesn't work.
> I just need to fire up the editor with ediff-files on those three files,
> which at the call moment are part of the environment (I think).
> Not sure I need the getenv but the thing is that I have no way to get
> the f***** actual command used by git for emerge.
> I tried all possible magic combinations with git config, but no way it
> doesn't spit it out..
> Any help is welcome :)
> Thanks

I didn't in the easiest place, what process is started by git, and here
the command (I added the -Q)

--8<---------------cut here---------------start------------->8---
cmd =Emacs -Q -f emerge-files-with-ancestor-command $LOCAL $MERGED $REMOTE
--8<---------------cut here---------------end--------------->8---

it's already much better, but I would like to use emacsclient instead,
still not working there though :(

reply via email to

[Prev in Thread] Current Thread [Next in Thread]