[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

interaction with gnuplot

From: Federico Beffa
Subject: interaction with gnuplot
Date: Tue, 17 Aug 2010 14:09:50 +0200

Hi All,

I'm on WinXP SP3 with emacs 23.1.1 and gnuplot 4.4.0 and gnuplot-mode 0.6.0. I would like to use gnuplot from inside of emacs. To do that I'm trying to use gnuplot-mode and have set (setq gnuplot-command "c:/Program Files/gnuplot/binary/pgnuplot.exe") in my .emacs.

In a file in gnuplot-mode I press C-c C-l to send a line with "plot [0:3] sin(x)" to gnuplot. Gnuplot starts and plots the function. However, emacs remains blocked waiting for something. If I press C-g emacs returns alive and I can continue. The same happens with every command I send to gnuplot.

To understand if the problem is with gnuplot-mode or with emacs itself, I tried to run pgnuplot from inside an emacs shell (M-x shell RET). Inside the shell I can execute (several) commands without having to press C-g after every command, but I do not see the gnuplot prompt. Could this be the reason for the abnormal behavior in gnuplot-mode? Any suggestion on how to fix gnuplot-mode under WinXP?


P.S. I tried emacs 23.2 and gnuplot 4.2 as well with the same results.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]