[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with msf-abbrev under Emacs 23

From: Seweryn
Subject: Re: Problem with msf-abbrev under Emacs 23
Date: Tue, 5 Oct 2010 07:17:40 +0000 (UTC)
User-agent: Loom/3.14 (

Darren Hoo <darren.hoo <at>> writes:
> I tested it  and I can use <choose> template, hit enter on the choice
> , a buffer pops
> which  I can choose from , I use emacs23 and msf-abbrev 1.0beta3.
> Though in c-mode, msf-abbrev work strangely, so I have to tweak
> c-mode-common-hook
> a little bit like:
>        (make-local-variable 'text-property-default-nonsticky)
>        (assq-delete-all 'category text-property-default-nonsticky)
> since emacs23 category is added to  text-property-default-nonsticky which 
> msf-abbrev  from working correctly in c-mode, but in other modes like
> python-mode
> ,it works ok ,that includes <choose> template methoned above.

Thank you for help. In fact I checked again with hitting RET and the <choose> 
template worked. I don't know why I had impression that before it had worked 
in other way. Perhaps it would be better to have a message to press RET when 
the <choose> template is used or make the option window pop up without 
pressing any key?

I also appreciate  the tip how to fix msf-abbrev in c-mode.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]