[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Emacs *inferior-lisp* process not starting

From: Markus Arike
Subject: Emacs *inferior-lisp* process not starting
Date: Wed, 27 Oct 2010 21:15:09 -0400
User-agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv: Gecko/20101013 Thunderbird/3.1.5

Hi everyone,

I'm running Emacs 23.2 (cocoa version) on OSX which had worked flawlessly. It is now broken. I previously had Emacs, Slime, and OpenMCL or SBCL set-up perfectly for the past few weeks and have been loving life, studying Lisp code daily. Last night, in trying to install Quack for Scheme, I may have changed some of the Emacs Preferences regarding Lisp, Inferior Lisp (?).

Now the *inferior-lisp* process is not starting when I start emacs, nor can I start it by typing M-x run-lisp. Typing 'M-x run-lisp' returns the error message:

"Can't exec program: /Applications/"

And where Emacs lists the open buffers, reads *inferior-lisp* [(Inferior Lisp:no process)]. Yikes.

All the Emacs versions on my Mac return the same error message, including GNU Emacs 22.1.1 (mac-apple-darwin) Terminal version. It returns the same message but obviously with a different path:

"Can't exec program: /usr/libexec/emacs/22.1/mac-apple-darwin/env"

I think that *inferior-lisp* opened at startup previously and now, because of my silly tinkering, it does not. Does anybody know how if this can be corrected?

I reinstalled Emacs, and it is the same story. I must have made some global change that is effecting all my installed Emacs. I started with a no .emacs file, and it is still broken. Can anyone kindly offer me any advice on how I can restore my Emacs to it's pristine configuration? Thanks so much.

Markus Arike
Troubled Emacs user.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]