[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

smtpmail/starttls starts connection but never sends

From: Joost Kremers
Subject: smtpmail/starttls starts connection but never sends
Date: 13 Nov 2012 20:30:31 GMT
User-agent: slrn/pre1.0.0-18 (Linux)

Hi all,

I'm running Emacs 24.2 on OS X Lion (more precisely, I'm using the
emacs-mac-port from <>) and
using it for email with mu4e. The other day, I ran into a problem with
sending mail, in that I can't anymore...

The emacs-mac-port is compiled without tls, so it uses the external
gnutls program for establishing tls connections, which worked fine,
until Homebrew upgraded gnutls. The problem is that gnutls-cli stopped
accepting certificates that cannot be verified. As a result, the
connection would be dropped and Emacs would tell me that no smtpmail
process was running. (Note: mu4e uses message-mode for composing and
smtpmail for sending email, so this issue shouldn't be mu4e-specific).

After some googling, I found that one way to get around this *should* be
to establish a connection manually once with the --tofu option, accept
the certificate when asked to, and then add the --tofu option to
starttls-extra-arguments, as explained in a post to gnu.emacs.gnus:

In my case, this doesn't entirely work, however. Although the connection
appears to be established, nothing is actually sent. I get the following
message in the minibuffer:

Opening STARTTLS connection to `'...done

and that's where it stays. Emacs is locked, the message buffer remains
open and active and nothing happens. I have to hit C-g to get control

Anyone know what might be going on, or how I could debug this further?


Joost Kremers                            
Selbst in die Unterwelt dringt durch Spalten Licht

reply via email to

[Prev in Thread] Current Thread [Next in Thread]