[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

emacsclient Mac OS X 'No socket or alternate editor' error

From: Charles Magid
Subject: emacsclient Mac OS X 'No socket or alternate editor' error
Date: Fri, 30 Nov 2012 08:01:30 -0800 (PST)
User-agent: G2/1.0

Emacsclient Mac OS X 'No socket or alternate editor' error

How it was invoked and what gets returned:

                $ /usr/local/bin/emacsclient ~/pgadmin.log 
                /usr/local/bin/emacsclient: can't find socket; have you started 
the server?
                To start the server in Emacs, type "M-x server-start".
                /usr/local/bin/emacsclient: No socket or alternate editor.  
Please use:

                        --server-file      (or environment variable 
                        --alternate-editor (or environment variable 

Upstream errors I thought I solved but perhaps not:

                        M-x server-start

                        Getting errors like

                        (error "The directory 
`/var/folders/b3/9k90h2ln2ns__vznkc0642vc3m01mw/T//emacs121636508' is unsafe")

So I verified it used the same file repeatedly then did a 

    $ chmod 700 emacs121636508

    After than M-x server-start returned without errors

To see if it was fixed in a later version I just reinstalled emacs with

                $ brew install emacs --cocoa --use-git-head --HEAD
                $ mv /usr/local/Cellar/emacs/HEAD/ /Applications/

    That didnt fix it

As an experiment yesterday I redefined

    (defun server-ensure-safe-dir (dir) t) 

    and it worked.

                But today the same trick did not work so I did the chmod 700 
and that seemed to work, but failed when I went to start emacsclient.

Thank you in advance for taking the time to look at this issue.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]