[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Giving up on colors, I need help

From: William D. Colburn (Schlake)
Subject: Giving up on colors, I need help
Date: Fri, 22 Feb 2013 11:27:42 -0700

Since October of 2007 I've fought an ever losing battle against emacs.
 I want to be able to see the words on the screen.  Either black words
on a white screen or white words on a black screen.

I'm finally defeated.  My last stand had been, for the past few years,
to always type ESC-x text-mode every time I started emacs to make the
screen readable.  But now, at my new job running 21.4.1 the colors
remain even in text mode.

Back in 2007 I did (global-font-lock-mode 0), but that stopped working
years ago.  I added (defun turn-on-font-lock () "Turn off Font Lock
mode because it sucks."  (global-font-lock-mode 0)) to keep it from
happened, but that doesn't do anything anymore.  I tried (setq
font-lock-maximum-size -1) and (setq font-lock-maximum-size 0) and
(setq font-lock-maximum-size 1) but none of those helped.  For my
frequently used mode I tried (add-hook 'python-mode-hook (lambda ()
(global-font-lock-mode nil))) and (add-hook 'python-mode-hook (lambda
() (font-lock-mode nil))) but that didn't work.  I had been using
--color=no on the command line, which didn't really work either, and
which no longer exists.

And now that ESC-x text-mode doesn't work anymore I'm stumped.  What
on earth do I have to do to turn off colors?  Why is this so hard?
What am I missing?

void *(*(*schlake(void *))[])(void *);

reply via email to

[Prev in Thread] Current Thread [Next in Thread]