[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Loading themes

From: Sharon Kimble
Subject: Loading themes
Date: Thu, 20 Feb 2014 11:58:12 +0000

I have the strange problem in that if I load a theme using 
'M-x load-theme' and then put in a theme name when prompted like 'brin'
it only shows the theme background colour in the fringe and the
mode-line and nowhere else. Its the same whatever theme I load. The
relevant section from my .emacs is here -

;;(add-to-list 'load-path
;;(add-to-list 'load-path
;;(require 'color-theme) 
;;(require 'color-theme-tomorrow) 
;;(eval-after-load "color-theme" 
;;  '(progn
;;     (color-theme-initialize)
;;     (color-theme-lethe)))
;;    (tomorrow-day-theme))
;;(defface popup-mouse-face nil nil)
;;(defface ac-candidate-face nil nil)
;; Please set your themes directory to 'custom-theme-load-path
;;(require 'remember-theme)
(add-to-list 'custom-theme-load-path
 (file-name-as-directory "/home/boudiccas/git/replace-colorthemes"))
(add-to-list 'custom-theme-load-path "/home/boudiccas/.emacs.d/themes")
(add-to-list 'custom-theme-load-path "/home/boudiccas/.emacs.d/elpa")

;;(require 'remember-theme)
;; load your favorite theme
;;(load-theme 'solarized-light t t)
;;(load-theme 'solarized-dark t t)
;;(enable-theme 'solarized-dark)

The only time that the theme background colour in the main window, where
all the code is, shows is when I highlight some text. The rest of the
time there is no background colour in the main window.

I've tried removing from ELPA the theme that was continually being
called when I started up .emacs, which was "grandshell", and this
morning I've removed "remember-theme" which was calling the old theme
on every launch of .emacs. 

Now I have no theme loaded, but when I do load one like "brin", it only
shows as in the screen-shot attached.

How can I get it so that themes work normally and display properly
please? I've tried using an old backed-up .emacs from twenty-four
hours ago, before the problem started, but it still shows as in the

I have a slight memory of putting some code in my 'setup-testbed.el'
file that would draw a rectangle round the working pane of .emacs. This
would have shown round all the working code, or document that was
displayed. I no longer have this code in my 'setup-testbed', and cant
find where I got it from, but it still seems to be having an effect
and causing the problem that I now have. 

Can anyone help in this strange problem please?

A taste of linux =
my git repo =
Debian testing, Fluxbox 1.3.5, emacs
Registered Linux user 561944

Attachment: Screenshot - 200214 - 11:44:39.png
Description: PNG image

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]