help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Tool bar icons not correct


From: Thomas S. Dye
Subject: Re: Tool bar icons not correct
Date: Thu, 06 Mar 2014 14:19:02 -1000

Michael Heerdegen <address@hidden> writes:

> address@hidden (Thomas S. Dye) writes:
>
>> Aloha all,
>>
>> I'm using Emacs 24.3 (9.0) that I built with MacPorts. I have the latest
>> Mac OS Mavericks.  
>>
>> When I start up, the tool bar icons are correct, but after I've worked a
>> while they begin to get confused. In particular, icons from closed
>> buffers begin to show up in buffers where they don't belong.  I notice
>> this often when I use gnus and switch back to editing a LaTeX file or
>> start working with Org mode. Just now, the icon to compile the LaTeX
>> file has some kind of mail icon.
>>
>> I haven't the faintest idea how to debug this. Can someone point me in
>> the right direction?
>
> AFAIK, the tool bar should always reflect the binding of `tool-bar-map'
> in the current buffer.  Maybe M-: (force-mode-line-update) or M-:
> (redraw-frame) helps?  Anyway, if it's not due to your setup, this
> sounds like a bug to me.

Thanks Michael. I was able to confirm that the tool bar doesn't reflect
the binding of `tool-bar-map', so I filed a bug report.

All the best,
Tom

-- 
T.S. Dye & Colleagues, Archaeologists
735 Bishop St, Suite 315, Honolulu, HI 96813
Tel: 808-529-0866, Fax: 808-529-0884
http://www.tsdye.com



reply via email to

[Prev in Thread] Current Thread [Next in Thread]