help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Possible problem using emacs on mounted filesystem.


From: Barry Margolin
Subject: Re: Possible problem using emacs on mounted filesystem.
Date: Wed, 26 Mar 2014 19:15:50 -0500
User-agent: MT-NewsWatcher/3.5.3b3 (Intel Mac OS X)

In article <address@hidden>,
 glen stark <address@hidden> wrote:

> Hi everyone.  
> 
> I'm not sure if this is an OS problem or an emacs problem.  The problem 
> only manifests itself for me on emacs, so I'm starting there.
> 
> I have a folder on an older linux server that I mount with the command:
> 
> sudo mount -t cifs -o username=xxx,uid=xxx //pdxenlin66/home/stg xenlin
> 
> I use emacs to edit the file.  I edit fine, but when I save the file, the 
> next time I try to edit the buffer I get the message "X changed on disk; 
> really edit the buffer?".
> 
> Does anyone have any idea what's going on here?  This is the first time I 
> have such an issue.
> 
> Thanks,  Glen

I think this typically means that the clocks are not synchronized 
between the client and server. The server's clock is ahead of the 
client, so when you save the file its modification time is newer than 
the time you saved.

Make sure you're running NTP on all machines to keep their clocks in 
sync.

-- 
Barry Margolin, address@hidden
Arlington, MA
*** PLEASE post questions in newsgroups, not directly to me ***


reply via email to

[Prev in Thread] Current Thread [Next in Thread]