help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Build emacs on debian


From: Harry Putnam
Subject: Re: Build emacs on debian
Date: Sun, 06 Apr 2014 21:28:23 -0400
User-agent: Gnus/5.130008 (Ma Gnus v0.8) Emacs/24.0.92 (gnu/linux)

hubert <address@hidden> writes:

> On Sun, 06 Apr 2014 19:49:51 -0400, Harry Putnam <address@hidden> said:
>
>> Oddly that ended poorly.... not sure why: sudo apt-get build-dep
>> emacs24
>
>>   Reading package lists... Done Building dependency tree Reading state
>> information... Done E: You must put some 'source' URIs in your
>> sources.list
>
>> I'm pretty sure I don't need source pkgs to build emacs so must be
>> something else going on.
>
> It needs the deb-src urls so that it can fetch the source package
> description to install the build dependencies.  If you don't want to add
> the deb-src urls, then you can download the dsc file manually.  Just go
> to https://packages.debian.org/sid/emacs24, and click on the .dsc file
> listed on the right-hand side.  Then look at the Build-Depends line.
> That's a list of all the packages that are needed to build.


One thing on that: The list does not mention xorg-dev.  Apparently
that would mean that xorg-dev is not a dependency then eh?

For the record, I'm not looking to 'apt-get install' emacs24, although
I'm pretty sure somewhere along the line apt-get is going to want to.
I just want to build emacs-24.4 from bzr sources myself.

I've got everything up to the 'configuring' wired.  bzr branch etc.
And have built emacs quite a few times over the last 6-7yrs or so.

Its just been such a good while this time that whatever I'd learned
has slipped out of my pea brain. 

List of deps:
bsd-mailx | mailx, libncurses5-dev, texinfo, liblockfile-dev,
librsvg2-dev, libgif-dev | libungif4-dev, libtiff4-dev | libtiff-dev,
xaw3dg-dev, libpng-dev, libjpeg-dev, libm17n-dev, libotf-dev,
libgpm-dev [linux-any], libdbus-1-dev, autoconf, automake,
autotools-dev, dpkg-dev (>> 1.10.0), quilt (>= 0.42), debhelper (>=9), 
libxaw7-dev, sharutils, imagemagick, libgtk-3-dev, libgnutls-dev,
libxml2-dev, libselinux1-dev [linux-any], libmagick++-dev,
libgconf2-dev, libasound2-dev [!hurd-i386 !kfreebsd-i386
!kfreebsd-amd64]




reply via email to

[Prev in Thread] Current Thread [Next in Thread]