help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cant type unicode in emacs any more


From: Eric Abrahamsen
Subject: Re: Cant type unicode in emacs any more
Date: Tue, 29 Apr 2014 20:44:45 +0800
User-agent: Gnus/5.13001 (Ma Gnus v0.10) Emacs/24.3 (gnu/linux)

Rusi <address@hidden> writes:

> For some time now I have this in my X startup programs:
> $ setxkbmap -option compose:menu
>
> After this I can type (in mostly any window) for example:
> (with MN being the windows-menu key)
> MN.. gives ...  ie an ellipses
> MN--. gives - ie an en dash
> MN--- gives -- ie an em dash
> Not to mention all the e" giving ë
> etc etc - all the unicode goodies at
> /usr/share/X11/locale/$LANG/Compose
>
>
> Now suddenly its stopped working.
> ie it works in most other X apps but not in emacs
>
> I thought there may be a race-condition between the setxkb and emacs
> which are both in my startup programs.
> So I ran the setxkb command by hand from a shell and (re)started emacs
> from the shell
>
> No luck:
> The compose works outside emacs
> Doesn't work inside
>
> Any clues?
>
> Its the same for emacs 23 and 24

Many of us have had to start emacs with the XMODIFIERS environment
variable *unset* for quite some time, to make this work:

/usr/bin/env -u XMODIFIERS /usr/bin/emacs

If I recall correctly, the emacs developers have caught this and fixed
it (?) in the development trunk, but I wouldn't be surprised if that
hasn't made its way to any releases yet. Why you've only bumped into
this recently I can't say, though again I have a feeling that one of the
linux distros updated not too long ago in a way that exposed this bug.
Anyhow, try unsetting the environment variable and see if that's it...

E




reply via email to

[Prev in Thread] Current Thread [Next in Thread]