[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: visiting remote files on webserver

From: Eric Abrahamsen
Subject: Re: visiting remote files on webserver
Date: Fri, 22 Aug 2014 09:16:27 +0800
User-agent: Gnus/5.130012 (Ma Gnus v0.12) Emacs/24.4.50 (gnu/linux)

lee <address@hidden> writes:

> Eric Abrahamsen <address@hidden> writes:
>> lee <address@hidden> writes:
>>>>> In this particular case, I wanted to get a script from some web
>>>>> server I don't have any special access to.  I could have downloaded
>>>>> and saved and visited it, but why not load it directly into a
>>>>> buffer.
>>>> The url package does this, you could start with url-retrieve and
>>>> url-retrieve-synchronously.
>>> Hm, yes, I thought it did, and there are a number of url-.* functions
>>> available, like url-handler-mode.  There aren't any to retrieve an url,
>>> though.
>>> Is the url package part of emacs, or do I need to install it?
>> I'm using emacs 24.4 (dev version) and it's in lisp/url/url.el.
> Hm, I have:
> [~/inst/emacs/emacs-git/emacs/lisp/url] find . -type f -print0 | xargs -0 
> grep -i "defun url-retrieve"
> ./url.el:(defun url-retrieve (url callback &optional cbargs silent 
> inhibit-cookies)
> ./url.el:(defun url-retrieve-internal (url callback cbargs &optional silent
> ./url.el:(defun url-retrieve-synchronously (url &optional silent 
> inhibit-cookies)
> Yet when I try M-x url-retrieve, there is no such funktion.
>> Everything's autoloaded properly, so url-retrieve is available from
>> startup. I know nothing about the history of this package -- what's your
>> emacs version?
> Please see below; I have gnus put version info into the signature for
> the emacs.* groups.  I compiled from the git repo from which I updated
> only a couple days ago (and it still seems to be a repo I'm not supposed
> to use).
> I tried (require 'url) in ~/.emacs, and that doesn't make a difference.
> I'll have to look into it more closely on the weekend ...  I suppose it
> should just be available.
> The first mentioning of url-retrieve in git log is in commit
> 40c5a1bd1b125e9768aa223e80d0ae32e33a184b from Mon Apr 12 20:50:16 2004
> +0000, authored by Stefan Monnier.  So it has over 10 years of history.

Yup, looks pretty weird -- particularly that you can require 'url and it
still doesn't work...

reply via email to

[Prev in Thread] Current Thread [Next in Thread]