[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Magit reports binary files that don't exist

From: Thorsten Jolitz
Subject: Re: Magit reports binary files that don't exist
Date: Sat, 23 Aug 2014 23:31:40 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3 (gnu/linux)

Nicolas Richard <address@hidden> writes:

> Thorsten Jolitz <address@hidden> writes:
>> Nicolas Richard <address@hidden> writes:
>>> Thorsten Jolitz <address@hidden> writes:
>>>> however I (and even somebody else at that time) tried it on a certain
>>>> problem and it was not reliable, only the literal NUL worked
>>>> always. 
>>>> There must be a thread on the Org mailing-list about this. 
>>> I did not manage to find it (searched for the term "NUL" and your email
>>> address on the gmane interface).
>> Its this thread (you were even involved ;):
> Err, that's embarassing. Thanks for finding it.

I don't think so, forgot about it too ...

> Re-reading the thread, I don't see where a difference between "\000" and
> "<actual NUL>" is mentionned.
> I do, however, see some confusion between "\000" (a string of one NUL
> char) and "\\000" (a string of 4 chars : backslash, followed by three
> 0's), e.g. the regexp "^aPDU[^\\000]+[}]+?$" is mentionned (at
> Perhaps that would explain the oddities ?

Yes, thats quite likely, because at that time I just discovered this
(most useful) 'regexp trick', and maybe I automatically escaped the
backslash  at some point without noticing. 

I switched to the 'Org version' again now (from literal NUL). Its not
really such a good idea to have literal NULs in source files ...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]