[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compiling Emacs: configure --with-x-toolkit=KIT

From: Javier
Subject: Re: Compiling Emacs: configure --with-x-toolkit=KIT
Date: Wed, 27 Aug 2014 21:41:54 +0000 (UTC)
User-agent: tin/2.2.0-20131224 ("Lochindaal") (UNIX) (Linux/3.14.2-1-ARCH (x86_64))

>>> I compiled and installed emacs from the source 24.3. But I appear to
>>> have created the GTK version and not the X11 version. Is there some
>>> other source which will produce emacs-x11? I tried

Do you mean the old-fashioned athena toolkit?

>From ./configure --help:
--with-x-toolkit=KIT    use an X toolkit (KIT one of: yes or gtk, gtk2,
                        gtk3, lucid or athena, motif, no)

The choices are gtk, lucid (same as Qt), athena and motif.

Try this

./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
--localstatedir=/var --with-x-toolkit=athena \
--without-gconf --without-gsettings
make install

If it does not work try --without-xft in the configure line.

Does it compile? does it look all right?  I have never tried to put
that look into emacs, but I confess that I like the minimalistic look
of the old athena X11 applications like xterm, xfig.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]