[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: AUCTeX PDF2DSC error on preview

From: benwr
Subject: Re: AUCTeX PDF2DSC error on preview
Date: Wed, 4 Feb 2015 14:26:51 -0800 (PST)
User-agent: G2/1.0

On Wednesday, February 4, 2015 at 3:03:27 AM UTC-5, Tassilo Horn wrote:
> If you have time to, you could edebug `preview-pdf2dsc-sentinel' to see
> where exactly the error comes from.

Thanks for the reply! When I turn on debug-on-signal, I get this:

> Debugger entered--Lisp error: (wrong-type-argument arrayp nil)
>   replace-regexp-in-string("[^-0-9a-zA-Z_./\n]" "\\\\\\&" nil)
>   shell-quote-argument(nil)
>   mapconcat(shell-quote-argument (nil 
> "-dOutputFile=(_region_.prv/tmp1671KOM/pr1-%d.png)" "-q" "-dDELAYSAFER" 
> "-dNOPAUSE" "-DNOPLATFONTS" "-dPrinted" "-dTextAlphaBits=4" 
> "-dGraphicsAlphaBits=4" "-sDEVICE=png16m" "-r110.418x110.613") " ")
>   preview-gs-restart()
>   byte-code("\306!\211\307=\2035\310!\210\311\312\f!P\313 \210
\203B\203(\314 \210\202B\203B\311\315\316\217\210\202B 
\317=\203B\310!\210\320 \210)\311\207" [process status TeX-sentinel-function 
preview-gs-init-string preview-colors gsstart process-status exit 
delete-process nil preview-pdf-color-string preview-prepare-fast-conversion 
preview-gs-restart (preview-delete-file preview-ps-file) ((file-error)) signal 
preview-dvips-abort preview-gs-queue preview-ps-file] 4)
>  preview-pdf2dsc-sentinel(#<process Preview-PDF2DSC> "Preview-PDF2DSC" t)
>   (lambda (process command) (preview-pdf2dsc-sentinel process command 
> t))(#<process Preview-PDF2DSC> "Preview-PDF2DSC")
>   TeX-command-sentinel(#<process Preview-PDF2DSC> "finished\n")

I'm not very adept with emacs yet (obviously) and it's getting to be really 
frustrating. The first time I tried to use edebug I made a mistake, and every 
time I've tried since, edebug doesn't seem to start after I instrument the 
function. I even moved my .emacs.d and reinstalled auctex, and it still won't 
run. Is there some other place where persistent settings are stored besides 
.emacs.d? Any ideas regarding either problem would be greatly appreciated.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]