[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Groovy script that reads stdin fails with "

Subject: Groovy script that reads stdin fails with " unknown protocol: c" when run with "shell-command-on-region"
Date: Thu, 12 Feb 2015 20:54:11 +0000

I'm using Emacs in Cygwin on Win7.

I have a Groovy script that reads from stdin, and it works fine when I run it 
from Bash, piping text into the process.

I'm now trying to select text in an Emacs buffer, and then execute 
"shell-command-on-region"  The text I'm selecting appears to be identical to 
what I'm sending on the command line.

When I run this, it fails with " unknown 
protocol: c".

This obviously has something to do with my PATH, but I'm not sure what could be 
wrong.  This might be more of a Cygwin question than an Emacs question.  I 
tried going into my "*scratch*" buffer and printed out the PATH that the 
process sees, and it obviously has entries in "/c/..." (I set my cygdrive 
prefix to "c").

reply via email to

[Prev in Thread] Current Thread [Next in Thread]