[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Help debugging a backtrace

From: Kaushal Modi
Subject: Help debugging a backtrace
Date: Wed, 27 Apr 2016 18:28:40 +0000


I was experimenting running emacs on Android using Termux ( ) inspired by this
blog post by Artur Malabarba ( ).

I have got things almost working except for seemingly random error messages
like the one in the below backtrace.

Here, I was trying to use the er/expand-region command ( ). That in turn seems to
require clojure-mode (as I happen to have that installed too). And after
that it leads to this error:

Debugger entered--Lisp error: (wrong-type-argument stringp (require .

(require . finder-inf))

  eval-after-load("clojure-mode" #[nil "\300\301!\207" [require
clojure-mode-expansions] 2])

.. which I do not understand how and why.

I have seen the same (require . finder-inf) error pop-up when I tried to do
something in dired too.

This problem did not occur for the short time I tried out emacs -Q. This
problem also does not occur as soon as I launch emacs with my config in
Termux; it happens only when certain packages are required.

I'd like to understand the above backtrace so that I can possible fix
something in my config or at least understand if something went wrong in
the building of emacs for that platform.

Thanks for reading my email.


Kaushal Modi

reply via email to

[Prev in Thread] Current Thread [Next in Thread]