[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

frame-cmds enlarge-font

From: Gauthier Östervall
Subject: frame-cmds enlarge-font
Date: Fri, 16 Dec 2016 11:04:53 +0100

I want the functionality of zoom-frm or default-text-scale (zooming in
on all windows of a frame).

I installed both via elpa, but none worked. The first zoom worked,
then nothing more. A little investigation hints that the problem is
with frame-cmds.el, and its function enlarge-font.

This seems to relate to an ancient but (#119 and #1562), Emacs 23. I
am currently on Emacs 24.4.1 because Debian.

There is a comment in frame-cmds.el, with a work-around for this bug.
I tested it to no av, but I'm not sure I did it right:
- replaced frame-cmds.el function enlarge-font with the work-around.
Recompile with (byte-recompile-directory package-user-dir nil 'force),
start a new emacs instance. This seems to work better when I call
enlarge-font directly, although 1 and -1 as parameters don't always
work. zoom-frm's command zoom-in still works only once.

For now I will just define my-enlarge-font in my init.el as what is in
the comment in frame-cmds.el, and call that directly. It would have
been nice to have the extra functionality of zoom-frm, but I'm not
sure what the correct way to do that: modify frame-cmds, recompile,
make zoom-frm use that.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]