[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cannot disable paren matching

From: John Mastro
Subject: Re: cannot disable paren matching
Date: Tue, 27 Dec 2016 13:30:24 -0800

Don Woods <> wrote:
> I am having a problem where paren matching is not working as desired,
> and I am unable either to turn it off or to make it work correctly.
> The specific case where I'm having trouble is in PostScript mode,
> when also in Overwrite mode.  When I type a character that acts as a
> close paren -- such as > or } -- the character is inserted instead of
> overwriting the current char.  Emacs briefly highlights the matching
> open paren, or reports a mismatch, as the case may be, but does NOT
> remove the char I was intending to overwrite.
> Since I don't especially need the paren highlighting in my current
> editing, most of my attempts to work around this bug have involved
> trying to disable the paren-matching behavior.  I have tried such
> things as
> (show-paren-mode 0)     ;; no noticeable change
> (show-paren-mode nil)   ;; no longer shows matching open
>                         ;; but still does not overwrite
> (modify-syntax-entry ?> "w" ps-mode-syntax-table)
>                         ;; > now highlights the char AFTER the matching <
>                         ;; but still does not overwrite
> (modify-syntax-entry ?< "w" ps-mode-syntax-table)
>                         ;; when combined with previous, > goes back to
>                         ;; showing matching <, but still does not overwrite
> I know I've tinkered with other paren-related vars without success,
> but no longer recall everything I tried.
> My only successful workaround so far is to scrap postscript-mode and
> use fundamental-mode.  I'm using overwrite-mode while editing a portion
> of the PostScript file that is a block of "ascii art" data, so don't
> really need postscript-mode there, but it's awkward when switching
> between the data and code portions of the file.
> Note: emacs-version is:
> "GNU Emacs 22.1.1 (mac-apple-darwin)
>  of 2016-04-22 on"

I'm not totally sure I understand the scenario, but I tried to reproduce
this in Emacs 25 using the steps below and everything seemed to work as
intended. Specifically, at the end of the steps, the buffer contained

Here are the steps I tried:
  emacs -Q
  C-x b ps RET
  M-x ps-mode RET
  M-x show-paren-mode RET
  M-x overwrite-mode RET

If my recipe above would indeed trigger the problem you're describing,
perhaps using a newer version of Emacs would do the trick - Emacs 22 is
quite old (circa 2006 I believe).

If the recipe above does not capture the problem, can you provide
similar steps from "emacs -Q" that we can experiment with?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]