[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

capslock key mapped with keytweak seems to be unbound by Emacs w32

From: B. T. Raven
Subject: capslock key mapped with keytweak seems to be unbound by Emacs w32
Date: Sat, 26 Aug 2017 16:17:29 -0500
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Thunderbird/52.3.0

I have been using Emacs from version 21 through 24.3.1 and I recently noticed that the capslock key does nothing in w32 Emacs. Works in Word, Notepad, Wordpad, browser and every other application that takes keyboard input. C-h k shows nothing when capslock pressed (maybe it shouldn't; I never tried it before) The only new thing I've noticed in my .emacs is a canlock customization line that is used by gnus, a package I never use anymore. I commented out this line from customization and also everything in .emacs that mentioned gnus but I still get no functionality by pressing capslock in Emacs.

I should mention that I have reassigned the ctl, alt, windows, etc keys with the keytweak utility (edits scancode assignments in registry) and in fact the functionality of \| key and capslock are swapped but that first key still works in Emacs and both work everywhere but in Emacs. Are there any w32 Emacs packages that would mess with a scancode assignment and then reset it on exit from Emacs ???

Any help or even only insight into this problem would be appeciated.

Thank you,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]