[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: capslock key mapped with keytweak seems to be unbound by Emacs w32

From: John Mastro
Subject: Re: capslock key mapped with keytweak seems to be unbound by Emacs w32
Date: Sat, 26 Aug 2017 18:42:30 -0700

B. T. Raven <> wrote:
> I have been using Emacs from version 21 through 24.3.1 and I recently
> noticed that the capslock key does nothing in w32 Emacs. Works in
> Word, Notepad, Wordpad, browser and every other application that takes
> keyboard input. C-h k shows nothing when capslock pressed (maybe it
> shouldn't; I never tried it before) The only new thing I've noticed in
> my .emacs is a canlock customization line that is used by gnus, a
> package I never use anymore. I commented out this line from
> customization and also everything in .emacs that mentioned gnus but I
> still get no functionality by pressing capslock in Emacs.
> I should mention that I have reassigned the ctl, alt, windows, etc
> keys with the keytweak utility (edits scancode assignments in
> registry) and in fact the functionality of \| key and capslock are
> swapped but that first key still works in Emacs and both work
> everywhere but in Emacs. Are there any w32 Emacs packages that would
> mess with a scancode assignment and then reset it on exit from Emacs
> ???

I don't have any idea what the cause might be, but it sounds like it
would be worth checking whether the same situation holds in "emacs -Q".
That will answer whether any of your Emacs packages or customizations
are involved.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]