[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

oops! re: capslock problem sent to Eli only by mistake

From: B. T. Raven
Subject: oops! re: capslock problem sent to Eli only by mistake
Date: Mon, 28 Aug 2017 23:13:32 -0500
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Thunderbird/52.3.0

On 8/27/2017 09:50, Eli Zaretskii wrote:
>> From: "B. T. Raven" <>
>> Date: Sat, 26 Aug 2017 16:17:29 -0500
>> I have been using Emacs from version 21 through 24.3.1 and I recently
>> noticed that the capslock key does nothing in w32 Emacs. Works in Word,
>> Notepad, Wordpad, browser and every other application that takes
>> keyboard input.
>> C-h k shows nothing when capslock pressed (maybe it shouldn't; I never
>> tried it before)
> CapsLock should produce the effect you expect: upper-case letters when
> you press letter keys.  It does that here, in every Emacs version I
> ever used.
>> Any help or even only insight into this problem would be appeciated.
> Like others told you, begin by trying this in "emacs -Q".  If CapsLock
> doesn't work there as well, try disabling the key reassignment
> software you installed.

Thanks, Mario, John, and Eli. Running emacs -Q gave the same symptom, but rebooting w64 ver. 7 Ultimate fixed the problem. I usually just put OS to sleep at night and sometimes get away without rebooting for a few weeks but apparently MS garbage collection is not as good as Emacs'. It's still a mystery why keyboard entry worked outside of Emacs. Maybe it's because runemacs.exe and emacsclientw are not run from C:\Program Files or c:\Program Files (x86) but from c:\emac\bin.

Thanks again,


p.s. I am married to the keytweak software. Without that I would need a dedicated keyboard for emacs; maybe that's not a bad idea.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]